Apertium has moved from SourceForge to GitHub.
If you have any questions, please come and talk to us on #apertium on irc.freenode.net or contact the GitHub migration team.

Talk:Apertium on Ubuntu or Debian

From Apertium
Jump to: navigation, search

Contents

[edit] Installing on older versions

[edit] Dapper Drake (6.06 LTS)

Several programs that are needed cannot be installed easily on Dapper Drake, because the version available with apt-get are too old. We suggest to install a newer version of Ubuntu as for example Edgy Eft or Feisty Fawn

[edit] Edgy Eft (6.10)

This is guide to install Apertium under Ubuntu Edgy Eft, aka Ubuntu 6.10

[edit] Installing tarball (tar.gz)

The tarball howto is not finnished yet.


Go to http://sourceforge.net/project/showfiles.php?group_id=143781&package_id=159345 and download the latest version

tar xzvf lttoolbox-2.0.3.tar.gz (or put the name of a newer version) cd lttoolbox-2.0.3/ ./configure sudo su (enter your password) make

Go to http://sourceforge.net/project/showfiles.php?group_id=143781&package_id=157932 and download the latest version (2.0.3 as of June 2007)

tar xzvf apertium-2.0.3.tar.gz (or put the name of a newer version) cd apertium-2.0.3.tar.gz ./configure

[edit] Feisty (7.04)

[edit] From Ubuntu's repository

An old version of Apertium is available for Feisty (http://packages.ubuntu.com/feisty/libs/apertium)


Example: installing apertium and apertium-es-ca sudo apt-get install apertium apertium-es-ca or System -> Administration -> Synaptic -> Search apertium-es-ca -> Install


[edit] Gutsy Gibbon (7.10)

There is an apertium version in ubuntu repository and you can do the same like Feisty.

[edit] Hardy Heron (8.04 LTS)

There is an apertium version in ubuntu repository. Try with Synaptic There are backports of the Apertium 3.1 packages for Hardy at pgquiles' PPA

[edit] Next releases

Try with Synaptic

[edit] Changing these howTos

I think installation had better to be divided into two ways:

  • From binary or repositories
  • From SVN

the second is quite the same for all Linux and the first will need to be divided for different Linux.--Soroush 22:56, 21 March 2008 (UTC)

[edit] Recent comments

((((((((((((((((((ERROR 1))))))))))))))))))))<P>
*********************************there is no such directory lttoolbox,<BR> please provide other directions on getting this installed, thanks!!!!!!!!!!!!!!!!!!!!**************<BR>
what I did was just put lttoolbox folder myself manually into the apertium DIR<BR>
This allowed me to work up to point ERROR 2, further below.
cd apertium/lttoolbox

This should be fixed. - Francis Tyers 07:53, 19 August 2008 (UTC)


(((((((((((((((((((((((ERROR 2)))))))))))))))))))))))

 cd .. 
 cd apertium 

this is wrong, direction should likely be stating: return to /home/$USER/apertium (((((((((((((((((((((ERROR 2)))))))))))))))))))))))

(((((((((((((((((((ERROR 3)))))))))))))))))))))))))

This allows

./autogen.sh
PKG_CONFIG_PATH=/home/$USER/local/lib/pkgconfig ./configure --prefix=/home/$USER/local/<P>
((((((((((((((((((ERROR 3)))))))))))))))))))))))))<P>
Dead END
This should also be fixed.
If you have any more trouble, please don't hesitate to comment here, or on our irc channel or mailing list. - Francis Tyers 07:54, 19 August 2008 (UTC)
Note: We have packages for Gutsy/Hardy - Francis Tyers 07:57, 19 August 2008 (UTC)

Personal tools