Installation minimale depuis SVN

From Apertium
Jump to: navigation, search

In English

Contents

[edit] Installation d'apertium et d'une paire de langues

Si vous avez une bande passante ou un espace disque limité, vous pouvez envisager de télécharger et d'installer seulement 3 choses:

  • lttoolbox
  • apertium
  • la/les paire(s) de langues qui vous intéresse(nt)

Voici les commandes si vous voulez la paire Esperanto-Anglais (eo-en):

svn checkout https://svn.code.sf.net/p/apertium/svn/trunk/lttoolbox
svn checkout https://svn.code.sf.net/p/apertium/svn/trunk/apertium
svn checkout https://svn.code.sf.net/p/apertium/svn/trunk/apertium-eo-en

Pour voir les paires de langues disponibles, aller à l'adresse https://apertium.svn.sourceforge.net/svnroot/apertium/trunk/.

Note: certain paquets doivent être installés avant d'installer Apertium, voir les pages d'aide spécifiques aux système d'exploitation dans Installation pour savoir comment les indstaller.

Typiquement, Apertium est installé dans le répertoire /usr/local. Toutefois, si vous voulez l'installer ailleurs ou si vous ne voulez pas l'installer en mode root, faire:

PREFIX=/chemin/où/je/veux/Apertium
PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig
export PKG_CONFIG_PATH

Puis, dans les répertoire de lttoolbox et d'apertium, faire:

./autogen.sh --prefix=$PREFIX
make
make install
ldconfig

Attention : Si vous n'avez pas spécifié $PREFIX ou si vous ne savez pas ce que ça signifie alors faire:

./autogen.sh
make
make install
ldconfig

(Si vous ne spécifiez pas de prefixe, utiliser sudo avant les 2 dernières commandes.)

Ensuite, dans le répertoire apertium-eo-en, faire:

./autogen.sh --prefix=$PREFIX
make
make install

(Utiliser sudo avant la dernière commande si vous ne spécifiez pas de prefixe.)

[edit] Pour les paires de langues qui utilisent Constraint Grammar

Pour Breton → Français, et les autres paires qui utilisent Constraint Grammar, vous avez besoin de vislcg3. Vérifiez le avec:

svn co --username anonymous --password anonymous http://beta.visl.sdu.dk/svn/visl/tools/vislcg3/trunk vislcg3

et installez le comme apertium. Notez qu'il faudra avoir ICU installé auparavant (disponible sur la plupart des gestionnaires de paquets GNU/Linux, sur Arch Linux comme icu, sur Debian/Ubuntu comme libicu-dev).

[edit] Dépannage

[edit] Serveur proxy

Personal tools