Apertium has moved from SourceForge to GitHub.
If you have any questions, please come and talk to us on #apertium on irc.freenode.net or contact the GitHub migration team.

Prerequisites for openSUSE

From Apertium
(Difference between revisions)
Jump to: navigation, search
(nl)
Line 7: Line 7:
 
zypper install subversion libxml2 libxml2-devel libxslt1 libxslt-devel \
 
zypper install subversion libxml2 libxml2-devel libxslt1 libxslt-devel \
 
libtool libcpcre1 pcre-devel flex make automake autoconf gcc-c++
 
libtool libcpcre1 pcre-devel flex make automake autoconf gcc-c++
  +
</pre>
  +
  +
If you need [[Vislcg3#Installing_VISL_CG3|vislcg3/cg-proc/cg-comp]] (Constraint Grammar), you should also do:
  +
<pre>
  +
zypper install cmake icu libicu boost gperftools
 
</pre>
 
</pre>
   

Revision as of 09:49, 23 November 2013

This page shows how to install the standard dependencies of apertium (and related packages) on openSUSE.


Install the apertium dependencies with zypper like this:

zypper install subversion libxml2 libxml2-devel libxslt1 libxslt-devel \
libtool libcpcre1 pcre-devel flex make automake autoconf gcc-c++

If you need vislcg3/cg-proc/cg-comp (Constraint Grammar), you should also do:

zypper install cmake icu libicu boost gperftools

Once you've installed these packages, continue to Minimal installation from SVN.


See also

Personal tools