Apertium has moved from SourceForge to GitHub.
If you have any questions, please come and talk to us on #apertium on irc.freenode.net or contact the GitHub migration team.

Prerequisites for FreeBSD

From Apertium
(Difference between revisions)
Jump to: navigation, search
 
Line 3: Line 3:
 
=== Install Dependencies ===
 
=== Install Dependencies ===
 
For Standard Apertium Translation
 
For Standard Apertium Translation
pkg install bash gettext libgcrypt libgpg-error libiconv subversion libxml2 libxslt pcre pcre++ pkgconf autoconf automake libtool flex
+
pkg install bash gettext libgcrypt libgpg-error libiconv git libxml2 libxslt pcre pcre++ pkgconf autoconf automake libtool flex
   
 
If you need vislcg3/cg-proc/cg-comp (Constraint Grammar), you should also do:
 
If you need vislcg3/cg-proc/cg-comp (Constraint Grammar), you should also do:
Line 9: Line 9:
   
 
=== Compiling and Installing Apertium ===
 
=== Compiling and Installing Apertium ===
Now you can move on to [[Minimal_installation_from_SVN]].
+
Now you can move on to [[Installation#For those who want to install Apertium locally, and developers]].

Latest revision as of 03:55, 9 March 2018

This page was written by Jatin Luthra, a 2016 Google Code-in student, which explains how to install Apertium on FreeBSD

[edit] Install Dependencies

For Standard Apertium Translation

pkg install bash gettext libgcrypt libgpg-error libiconv git libxml2 libxslt pcre pcre++ pkgconf autoconf automake libtool flex

If you need vislcg3/cg-proc/cg-comp (Constraint Grammar), you should also do:

pkg install cmake icu boost-all gperf iperf iperf3 gawk

[edit] Compiling and Installing Apertium

Now you can move on to Installation#For those who want to install Apertium locally, and developers.

Personal tools