Install language data using packaging

From Apertium
Revision as of 13:38, 24 April 2017 by Rcrowther (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

You want to install one of the big language data sets. You do not want to add to or modify language data, you want to use it.

You could use a public repository[1] but you will be more up-to-date with the Apertium package repository.

[edit] The Apertium package repository packages

Contents

The Apertium package repository contains language data that is up-to-date, an up-to-date core, and much more. In the Apertium package repository, 'release'-level language data is compiled into packages. That's easy! Remember to say thankyou to the maintainers!

To access this data, if you have not done already, follow Install Apertium core using packaging. This will install the Apertium package repository, and then an up-to-date core (you could install the repository but not the core. I assume you have a special reason for doing this and know what you are doing).

[edit] About the Apertium Debian package repository

If you have loaded languages from the Apertium package repository, you may see two versions of a language data in your in your package index. You should use the version from the Apertium package repository. Debian packaging will have overwritten the defaults with the new versions, but you can use Synaptic to check. Look in properties > versions for apertium.projectjj.com.


[edit] Installing from repositories

[edit] Debian-based

[edit] check what is available

apt-cache search apertium

or,

 apt search apertium

[edit] Install language data

e.g.

 sudo apt-get install apertium-kaz-tat


[edit] Red Hat-based

[edit] check what is available

su -c 'yum list apertium\*'

[edit] Install language data

e.g.

su -c 'yum install apertium-kaz-tat'


[edit] Test

When they work, Install quick tests make the morning worthwhile.

[edit] Notes

  1. [edit] Using public repositories, such as Debian Stable

    Data may be outdated, use only for system assessment. See the main section on the Apertium package repository.

    It is possible you want to try public repository language packages. The author has done this sometimes, for various reasons. Beware that the packaging manager may install another (older) version of Apertium core, which can be confusing. And we warn against installing Apertium core from a public repository, because it can cause problems when developing. However, this is not so much a problem for language packages. The interface between core and language data is not guaranteed, but is stable. Apertium core, and several tools, can 'see' languages installed in different places (not true for all projects, but true for much of Apertium). So, if you want to quickly try out a language, go ahead, try installing. If it doesn't work, you can uninstall the data. That's a big advantage of packaging.

Personal tools